This was submitted to the help desk. Did I say it was my computer? Because it's not... God dammit Hannah, why won't you behave
Home Original Content Funny Pictures Funny GIFs YouTube Funny Text Funny Movies Channels Search

hide menu

This was submitted to the help desk

Did I say it was my computer? Because it's not.

+1673
Views: 65908
Favorited: 45
Submitted: 02/23/2013
Share On Facebook
Add to favorites Subscribe to cupcakedevourer E-mail to friend submit to reddit
Share image on facebook Share on StumbleUpon Share on Tumblr Share on Pinterest Share on Google Plus E-mail to friend

Comments(123):

[ 123 comments ]

Show All Replies Show Shortcuts
Show:   Top Rated Controversial Best Lowest Rated Newest Per page:
Order:
What do you think? Give us your opinion. Anonymous comments allowed.
#39 - Cleavland Steamer (02/24/2013) [+] (4 replies)
God dammit Hannah, why won't you behave
#2 - Einsty (02/23/2013) [-]
Just reinstal the OS and blow on RAM pins and it will be fine.
#45 - breakfastlunch (02/24/2013) [-]
They must have forgotten to download more RAM.
They must have forgotten to download more RAM.
User avatar #14 - immortalfear (02/24/2013) [-]
Did you try turning it off and back on?
#101 - electrickwalrus ONLINE (02/24/2013) [-]
have you tried pulling the plug out and putting it back in or system restore?
#53 - romdadon (02/24/2013) [+] (2 replies)
Comment Picture
#97 - hobomofo (02/24/2013) [+] (1 reply)
**hobomofo rolled a random image posted in comment #3287757 at My Little Pony fanfiction, backgrounds, songs, lyrics, and GIFs. ** never blew my load that hard
User avatar #100 to #97 - electrickwalrus ONLINE (02/24/2013) [-]
you blew it so hard it took both hands
#92 - eccleston (02/24/2013) [+] (1 reply)
User avatar #58 - manofparody (02/24/2013) [+] (9 replies)
I used to work as a bench technician for geek squad on the Dell line, I saw laptops like this come in a lot. We had one that was shot in a police raid that we replaced, and another had an arrow through it. Hell, we even had one that was ran over by a tank that we replaced.
+8
#112 - sandwitchman **User deleted account** has deleted their comment [+] (1 reply)
User avatar #36 - babyweewee (02/24/2013) [-]
Have you tried turning it off and on again?
#52 - heyfuckoff (02/24/2013) [-]
Did you try turning it off and back on?
#37 - locke (02/24/2013) [-]
I'm not sure, but this may be a software problem.
#86 - felixjarl (02/24/2013) [+] (7 replies)
I would suggest reformatting the hard drive.
I would suggest reformatting the hard drive.
+5
#118 - jimborustler **User deleted account** has deleted their comment [-]
+5
#1 - rainbowadash **User deleted account** has deleted their comment [-]
User avatar #51 - xxxJohnxxx ONLINE (02/24/2013) [-]
Dude, you just need to download some more ram
User avatar #35 - CiaranPM (02/24/2013) [-]
Looks like you need to use Chrome.
[ 123 comments ]
Leave a comment
 Friends (0)