x
Click to expand
What do you think? Give us your opinion. Anonymous comments allowed.
#101 - filipnocd (06/23/2013) [-]
MFW I saw this post.
#106 - hewhoepicfails (06/23/2013) [-]
Just put the damn thing out of its misery! It has no reason to suffer any longer from this **** !
#104 - triggerhappywolf ONLINE (06/23/2013) [-]
Comment Picture
User avatar #100 - revios (06/23/2013) [-]
oh god my eyes are bleeding
#98 - camelnuts (06/23/2013) [-]
For some reason this picture loaded quite slow for me, so I instantly thought it was just a gif messing with me, but I guess not. I need to upgrade my internet...
User avatar #95 - thedarkestrogue (06/23/2013) [-]
My parents computer is the same way. They blame me and my video games even though i havn't had a video game on that compute in years.
#90 - fukkentyranitar (06/23/2013) [-]
For what reason?
For what reason?
0
#88 - nikismeeee has deleted their comment [-]
User avatar #70 - fuckyouimapancake (06/23/2013) [-]
Had to help my mom out with a problem like this, the laptop literally sounded like it was screeching and it was hotter than the core of the sun.
User avatar #66 - rakaka (06/23/2013) [-]
holy **** dude if you're gonna post gore post it in morbid channel. Not everyone is a sick as you are
#64 - Berzer ONLINE (06/23/2013) [-]
User avatar #54 - gustaviaable (06/23/2013) [-]
The problem is that they are using internet explorer
#35 - rapebear (06/22/2013) [-]
Don't worry, he'll fix it.
#33 - pedobearRAW (06/22/2013) [-]
Comment Picture
User avatar #17 - szymonf (06/22/2013) [-]
have you tried tuning it off and turning it back on again?
or you could try taking out the battery.
User avatar #15 - grotesquefailure (06/22/2013) [-]
Just looking at that picture makes me want to press the off button.
#8 - anonymous (06/22/2013) [-]
Did you try deleting System32? Well there's your problem
User avatar #2 - kingpoopdog (06/22/2013) [-]
Did you try turning it off and on again?
 Friends (0)